2010年12月23日木曜日

GALAXY TABとPCの接続&アプリ転送

GALAXY TABをPCに接続しPCで作成したアプリを転送するメモ

1.まだUSBで接続していない状態で、
設定⇒アプリケーション⇒開発⇒USBデバッグ をチェック

2.USBでPCと接続
⇒失敗


3.Windows 7にはGalaxy SのUSBドライバが標準では入っていない様子。
http://www.samsung.com/uk/support/detail/supportPrdDetail.do?menu=SP00&prd_ia_cd=23030100&prd_mdl_cd=GT-P1000CWAXEU&prd_mdl_name=GT-P1000&prd_ia_sub_class_cd=P からSamsung Kiesをダウンロード


インストール



USBでGALAXY TABとPCを接続します。インストールできたようです。


4.Eclipseを起動し、転送したいプロジェクトを選択します。
メニューバーの実行⇒実行構成⇒ターゲットを手操作(マニュアル)に設定
下の実行をクリックするとデバイス選択画面が出てきます。
そこで接続しているGALAXY TABに相当するものを選びOKをすれば転送開始されます。


Android2.2とGoogleAPIs level8両方のターゲットで実行できました。

参考 http://juggly.cn/archives/13551.html

2010年12月19日日曜日

n-TSPメモ

ファジイc-means法を用いた複数巡回セールスマン問題の一解法より

k-tour splitting aigorithm
[STEP1]
全都市に対して、TSPを計算
⇒総経路長T、スタート地点と最も遠い拠点の距離Cmax

[STEP2]
1<=j

サブツアー長<(j/N)(T-2Cmax)+Cmax
を超えない最大の都市までが担当者jのサブツアー

[例]
拠点1⇒2⇒3⇒4⇒5⇒6⇒1
各拠点間すべて10
T=60
Cmax=18(1⇒4)
担当者3人

担当者1
(j/N)(T-2Cmax)+Cmax
=(1/6)(60-36)+25
=1/6*24+25
=4+25=29

担当者2
(j/N)(T-2Cmax)+Cmax
=(2/6)(60-36)+25
=8+25=33

担当者3
(j/N)(T-2Cmax)+Cmax
=(3/6)(60-36)+25
=12+25=37

疑問点
・担当者は29までのルートになるが1⇒2⇒3⇒1として3⇒1の距離は加算される?
・担当者2のルートは33までだが1⇒4⇒1は36だからルートを割り当てられない?

追記
・1⇒拠点⇒・・・⇒1でスタート地点から拠点と拠点からスタート地点も含めて計算(遺伝的アルゴリズムによる収集計画問題の解法より)

TSPメモ

MTSP:Multiple Traveling Salesman Problem
N人のセールスマンが、n個の都市を誰かが唯一度だけ訪問する
セールスマンは任意の都市からスタートできる

k-TSP(N-TSP):N人のセールスマンが共通の出発都市、帰還都市が同じです。

担当者負担均等化は重要

2010年12月10日金曜日

VIrtualbox 共有フォルダ設定

ホストOS側設定
D:\share を共有フォルダとする(何かテキストなど入れておきましょう test.txt)

ゲストOS側設定(Windows)
まずデバイス⇒共有フォルダ設定⇒上記のフォルダ指定
その後
> net use :z \\vboxsvr\share を入力
「正常に終了しました」⇒コンピュータから見られます。

ゲストOS側設定(Ubuntu:Virtualboxイメージ)
まずデバイス⇒共有フォルダ設定⇒上記のフォルダ指定
その後
1.Guest Additionsを追加
メニューの「デバイス > Guest Additions のインストール」 をクリック
マウントされたらクリックして実行

追記10.10の場合は
場所⇒VBOX・・・をマウント⇒CDマークをクリック⇒autorunでOK

2.マウント
$ sudo mount -t vboxsf share /mnt
$ ls /mnt とするとファイルが見える

vi /mnt/test.txt
これで変更するとWindows側でみても反映されている

2010年12月8日水曜日

Windows7での共有方法

Winodws7で共有をするメモです。

検証OS:Windows7 Enterprise2台
同じワークグループに属している

1.2台とも「ネットワーク場所の設定」⇒ホームネットワークに設定


2.1台でホームグループを作成
⇒パスワードを控えておきます。

3.もう1台で既存のホームグループに参加
⇒2のパスワードを入力します。

これでOK

計測自動制御学会発表

計測自動制御学会で「クラウドVPSの自動検証システム構築とその評価」について発表をしてきました。
学会で発表することは初めてだったので、非常に緊張しました。
発表については早口になってしまい時間を余らせてしまい、もっと落ち着いて話せばよかったと思っています。質疑応答についても、先生方に頼ってしまう結果となり残念です。次の機会があるのならば、今回の事をバネして、もっといい発表にしたいです。
他の発表者のテーマも中には初めて聞くものもありましたが、非常に興味深いものばかりで楽しんで聞くことができました。

2010年12月7日火曜日

計測自動制御学会発表


2010年11月25日に京都で開催された計測自動制御学会でパブリッククラウド運用基盤の提案という題名で発表を行ってきました。学会での発表は2回目だったのですが、やはり緊張することには変わりませんでした。自分の発表も前半は良くしゃべることができたと思ったのですが、後半はシュミレーション不足で原稿を読む形になってしまいました。もし次回機会があるのならば、しっかり最後まで流れの中で発表できるようになりたいです。
また、他の研究者の発表も興味深いものが多く非常に楽しい学会でした。

2010年12月4日土曜日

VPSで日本語を使う:SCIMの導入

VPSをVNCで接続できるようにしても、日本語入力ができないようです。
SCIMをインストールするときのメモです。

# yum install scim
# yum install anthy
# yum install scim-anthy
インストールが完了すると
システム⇒設定⇒他の個人設定⇒SCIM入力メソッドの設定 をクリック
必要な項目を設定します。

あとは
# scim &
とすれば「Ctr+Space」 で立ち上がります。


SCIMの終了方法
ps x | grep scim

kill ????
とプロセスIDを指定して終了後
scim &


2011/12/04 追記
# yum install scim
# yum install anthy
# yum install scim-anthy
を行ったあと、rebootしたらCTR+Spaceでそのまま使えました

ただし

#vi /root/.vnc/xstartup

#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &

LANG=ja_JP.utf-8
export LANG
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE=scim
export XMODIFIERS GTK_IM_MODULE
export LC_TYPE="ja_JP.utf-8" 追加
export QT_IM_MODULE="scim" 追加
scim -d & 追加

exec gnome-session &

としたら全角/半角キーも追加されました。
もちろんユーザ毎にxstartupに設定が必要です。


20120128追記
Macでもキー組み合わせを新規登録することで利用できました。

2010年12月2日木曜日

ファイアウォールの解放

linuxでファイアーウォールを解放しないとHTTPやFTPの接続ができないため、ポートを解放する方法の覚書

vi /etc/sysconfig/iptables
で最下行に
-A RH-Firewall-1-INPUT -m tcp -p tcp --dport 80 -j ACCEPT
-A RH-Firewall-1-INPUT -m tcp -p tcp --dport 21 -j ACCEPT
を追加。
番号を変更することによって対象のポートを解放できる。

2010年11月25日木曜日

onmのポート解放

ここのVPSには「遮断」がiptablesテーブルの一番下にはいっている。
その上に解放ポートを追加
⇒しかし
ファイアウォールルールを適用中: [ OK ]
チェインポリシーを ACCEPT に設定中filter [ OK ]
iptables モジュールを取り外し中 [失敗]
iptables ファイアウォールルールを適用中: [ OK ]
iptables モジュールを読み込み中ip_conntrack_netbios_ns [失敗]
となり、うまくいかない。
vi /etc/sysconfig/iptables-config
IPTABLES_MODULES="ip_conntrack_netbios_ns"⇒
#IPTABLES_MODULES="ip_conntrack_netbios_ns"
としたらうまくいった。

2010年11月24日水曜日

ポート全開放(iptables)、ポートチェックツール

ポート全開放
#iptables -A INPUT -p tcp --dport 1024:65535 -j ACCEPT

ポートスキャンツール(自分のサーバにのみ行う)
# yum install nmap
# nmap localhost

2010年11月22日月曜日

Basic 32-bit Amazon Linux AMI 1.0へのログイン

Basic 32-bit Amazon Linux AMI 1.0にログインするときのメモ(ちょっと困ったので)

・立ち上げ後、puttyでログインする場合はppkを登録しておく(いつもと同じ)
・rootではログインできないので「ec2-user」でログイン
・sudo su - でrootにユーザ変更

です。

2010年11月15日月曜日

Nagios ホストのグループ化

/etc/nagios/objects/group.cfgを作成
中身を
# web server
define hostgroup{
hostgroup_name servers
alias server group
members host1,host2,host3
}
# network
define hostgroup{
hostgroup_name networks
alias network group
members host4
}

/etc/nagios/objects/host1.cfg
を編集。
define hostgroup{
hostgroup_name servers
alias server group
members host1,host2,host3
}
をコメントに変更
以上でホストのグループ化ができます。
当然service nagios restart

追記:
vi /etc/nagios/nagios.cfgにcfg_file=/etc/nagios/objects/group.cfgを追加

2010年11月13日土曜日

2010/11/13 e-learning学会メモ(iphone)

青山学院大学iphone導入
[利点]
・先端技術を体験、知ることで提案ができるようになる
・iTune,Appストアの仕組みをしることで、世界的な流通を理解することができる
・先端技術を提供する⇒学生が喜んで自主的に勉強する
・つまり学生の悪影響(違う目的に使用、授業中のゲーム)より良い影響の方が大きいと考えている

[通信料金]
・WiFi環境だけで使用(3G料金は発生しない:定額の最低料金で設定)

[学生ボランティアの利用]

今後、Weekly試験をWeb試験に変更
・ランキング
・自主学習
・Weekly試験機能
など

2010年11月9日火曜日

Webminのインストール

webminをyumでインストールします。

1.リポジトリ作成
/etc/yum.repos.d/webmin.repo
[Webmin]
name=Webmin Distribution Neutral
baseurl=http://download.webmin.com/download/yum
enabled=0

2.GPG key 設定
rpm --import http://www.webmin.com/jcameron-key.asc

3.インストール
yum --enablerepo=Webmin install webmin

4.ポート変更
vi /etc/webmin/miniserv.conf
port=10000⇒任意の数字

5.起動
service webmin start

6.アクセス
http://ホスト名:ポート

7.日本語化
トップ画面から
Webmin->Change Language and Theme->Personal Choice Japanes(UTF-8)->Make Change
で再起動が掛かります。画面更新すると日本語です。

2011/03/03追加
初回ログインの時、何度やってもログインできなかった。
/usr/libexec/webmin/changepass.pl /etc/webmin root root用パスワード
の発行が必要らしい。


参考
http://ameblo.jp/nicebiz/entry-10429441062.html
http://jp.webmin.com/node/54
http://www.i2kt.com/linux/fedora/package/index_webmin.html

2010年11月8日月曜日

ベンチマーク:mysqlslap

MySQLを5.1.4以上にし、実行します。

mysqlslap --auto-generate-sql --auto-generate-sql-guid-primary --engine=myisam --number-int-cols=3 --number-char-cols=5 --concurrency=10 --auto-generate-sql-write-number=1000 --auto-generate-sql-execute-number=1000 --auto-generate-sql-load-type=mixed -p

Enter password: rootのパスワード

Benchmark
Running for engine myisam
Average number of seconds to run all queries: 1.141 seconds
Minimum number of seconds to run all queries: 1.141 seconds
Maximum number of seconds to run all queries: 1.141 seconds
Number of clients running queries: 10
Average number of queries per client: 1000

10クライアント当たり1000クエリーを実行して,1クエリーあたりの平均処理時間が,1.141秒となった。

mysqlclient16のインストール

mysqlclient16が必要なプログラムがあり、結構インストールに手間取りました。
しかもパッケージが不安です。

# yum --enablerepo=remi-test install mysqlclient16

Updating:
mysql-libs x86_64 5.5.6-1.el5.remi remi-test 1.9 M
Updating for dependencies:
mysql x86_64 5.5.6-1.el5.remi remi-test 1.8 M
mysql-server x86_64 5.5.6-1.el5.remi remi-test 11 M

バージョンが高い!。しかも下記の警告がでました。

WARNING : This MySQL RPM is not an official Fedora/Redhat build and it
overrides the official one. Don't file bugs on Fedora Project nor Redhat.
Use dedicated forums http://forums.famillecollet.com/

一応インストール完了です。

しかし、プログラムは動かず。
error while loading shared libraries: libmysqlclient.so.16: cannot open shared object file: No such file or directory

リポジトリremiの追加

既に、rpmforgeとepelは入っている状態です。

[root@rad-xen-vweb9 ~]# wget http://rpms.famillecollet.com/el5.i386/remi-release-5-8.el5.remi.noarch.rpm
--2010-11-08 10:47:54-- http://rpms.famillecollet.com/el5.i386/remi-release-5-8.el5.remi.noarch.rpm

[root@rad-xen-vweb9 ~]# rpm -Uvh remi-release-5-8.el5.remi.noarch.rpm

[root@rad-xen-vweb9 ~]# vi /etc/yum.repos.d/remi.repo
この中ではenable=0になっていました

[インストール]
# yum --enablerepo=remi,epel,rpmforge install パッケージ名
でやっていきます。

remiはepelとセット??

MySQL5.1へのアップグレード

mysqlslapを使ってベンチマーク検証をしたいので、mysqlを5.1にアップグレードしました。

# yum remove mysql*
で今まで入っていたものを削除(何もレコードが入ってなかったのでやってしまいました)

# yum --enablerepo=remi,epel,rpmforge install mysql-server

remiのインストールは別ページにあります。
注:install mysql としてインストールするとmysql がi386とx86_64が同時にインストールされ、i386がインストールできなかった。mysql-serverで依存性でmysqlをインストールするとうまくいった

Installing:
mysql-server x86_64 5.1.52-1.el5.remi remi 11 M
Installing for dependencies:
mysql x86_64 5.1.52-1.el5.remi remi 1.1 M
mysql-libs x86_64 5.1.52-1.el5.remi remi 1.7 M
mysqlclient15 x86_64 5.0.67-1.el5.remi remi 1.3 M
perl-DBD-mysql x86_64 4.014-1.el5.rf rpmforge 230 k

[root@rad-xen-vweb8 ~]# service mysqld restart
mysqld \u3092\u505c\u6b62\u4e2d: [ OK ]
mysqld \u3092\u8d77\u52d5\u4e2d: [ OK ]

これでアップグレードできました。

参考
http://www.multiburst.net/sometime-php/2009/05/centos-53-php-529-mysql-5134/

2010年10月26日火曜日

Openofficeのインストール

# yum -y install openoffice.org-core openoffice.org-langpack-ja_JP

とすると
Installing:
openoffice.org-core x86_64 1:3.1.1-19.5.el5_5.1 updates 110 M
openoffice.org-langpack-ja_JP
x86_64 1:3.1.1-19.5.el5_5.1 updates 18 M

インストール後
# soffice で起動

これだけではドキュメント作成の
ツールが何もはいっていない。


次に各機能をインストールする。
# yum -y install openoffice.org-writer openoffice.org-calc openoffice.org-impress openoffice.org-math openoffice.org-base openoffice.org-draw
とするとメニューに表示されるようになる
(メニューからは起動はするがフリーズしてしまった。#sofficeで起動して、メニューから選択すればうまくいった)

netperfでのベンチマーク

netperfを利用してネットワークスループットのベンチマークをとります。

1.インストール
yum --enablerepo=rpmforge install netperf

2.サーバ側起動
[root@rad-xen-vweb8 log]# netserver
Starting netserver at port 12865
Starting netserver at hostname 0.0.0.0 port 12865 and family AF_UNSPEC

ポート12865で起動
[why?]
ポートを12865だけ開けてもうまくいかなかった
netperf: send_tcp_stream: data socket connect failed: No error
port: 48488

3.クライアント側起動
[root@rad-xen-vweb9 ~]# netperf -H XXX.XXXXX.com
TCP STREAM TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to XXX.XXXXX.com (YYY.YY.YYY.YYY) port 0 AF_INET
Recv Send Send
Socket Socket Message Elapsed
Size Size Size Time Throughput
bytes bytes bytes secs. 10^6bits/sec

87380 16384 16384 10.29 1228.82
太字の部分をDBに格納

4.実行環境
サーバはVPS、アクセスするクライアントは学内PCから
C:\netperf>netperf-2.1pl1.exe -H XXX.XXXXX.com >>./log/log
_netperf.txt
ひとまず、ファイルに書き込んであります。

2010年10月25日月曜日

ベンチマークab

abでのベンチマークのメモ

同時 10 接続で 1000 リクエストを処理するまでの性能を計測
ab -n 1000 -c 10 http://localhost/ファイル名

HTMLファイル ht_test.html (HTML1行出力)
AB HTML

# ab -n 1000 -c 10 http://localhost/ht_test.html


PHPファイル php1_test.php (PHP1行出力)

# ab -n 1000 -c 10 http://localhost/php1_test.php



PHPファイル php2_test.php (PHP1~1000まで足し算、出力)

# ab -n 1000 -c 10 http://localhost/php2_test.php



今回DBに格納するデータとして
・Document_Path 調査ファイル名
・Server_Software Apacheのバージョン
Requests_per_second 1秒間に処理されたリクエスト数
・Transfer_rate 転送速度
ネットワーク環境の実効速度よりも遅いようであれば、ネットワーク環境のチューニングも考慮する。ネットワーク環境の実効速度は、そのネットワーク経路上の最も細い回線の60%程度とみればよい。

2010年10月20日水曜日

hdparamでの検証

hdparmでの検証です。

ddと同様12回行って最大値、最小値を除いた10回の平均をDBに格納します。

for i in [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] [11] [12];
do
sleep 7;

echo $'\n\n' $i >>/パス/log_hdparam.txt;
date >>/パス/log_hdparam.txt;
/パス/hdparm -t /dev/xvda2 >>/log_hdparam.txt;
done

[結果表示]
[1]
Wed Oct 20 10:03:28 JST 2010

/dev/xvda2:
Timing buffered disk reads: 46 MB in 3.02 seconds = 15.26 MB/sec


[2]
Wed Oct 20 10:03:55 JST 2010

/dev/xvda2:
Timing buffered disk reads: 296 MB in 3.01 seconds = 98.37 MB/sec

このsecondsの10回の平均値をDBにアップロードします。createdも入力します。

cronに登録
/パス/hdparm-9.29/hdp.sh;
echo >>/パス/log_hdparam.txt;
を毎時実行45分

CREATE TABLE IF NOT EXISTS `hdparams` (
`id` int(11) NOT NULL auto_increment,
`seconds` double NOT NULL,
`created` datetime default NULL,
`modified` datetime default NULL,
PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ;

ddでのベンチマーク検証

ddコマンドを利用してHD書き込みのベンチマーク検証を行います。
ddは結果が標準エラーで出力なので、ちょっと注意です。
結果はDBに格納しますが、ひとまずファイル出力で書いておきます。

[dd.sh]
for i in [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] [11] [12];
do
sleep 7;

echo $'\n\n' $i >>/log_dd.txt;
date >>/log_dd.txt;
dd if=/dev/zero of=/tmp/hdparm_write$i.tmp ibs=1M obs=1M count=1024 2>>/log_dd.txt;
done

これを実行すると([1][2]の間は空白2行)


[1]
2010\u5e74 10\u6708 20\u65e5 \u6c34\u66dc\u65e5 08:43:56 JST
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 6.91169 seconds, 155 MB/s


[2]
2010\u5e74 10\u6708 20\u65e5 \u6c34\u66dc\u65e5 08:44:13 JST
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 8.57898 seconds, 125 MB/s

これが[12]まで出力されます。
この155 MB/s,125 MB/sの最大値と最小値を取り除いた10回の平均値を求め、DBに格納します(他プログラム)。
DBフィールドはMBsとなっています。
InsertはMBsとcreatedフィールドに書き込みます。

CREATE TABLE `jacc`.`dds` (
`id` INT NOT NULL AUTO_INCREMENT PRIMARY KEY ,
`MBs` DOUBLE NOT NULL ,
`created` DATETIME NULL ,
`modified` DATETIME NULL
) ENGINE = INNODB



これをcronで1時間に1回実行します。
書き込みは空白3行空けています。

2010年10月18日月曜日

VNC一般ユーザ追加

http://sdc.sangi.jp/2009/08/amazon-ec2-gui.html の続きです

LinuxにVNC経由でアクセスする場合、一般ユーザで接続できるようにしておきます。

# vi /etc/sysconfig/vncservers
VNCSERVERS="1:root 2:jacc 3:sangi"
このようにrootの後に空白を挟んでユーザを追加する(当然存在するユーザを記述します)

対象ユーザに切り替え、VNC用パスワードを設定します(6文字以上)。


$ vncserver
でサービスを起動します。


/home/sangi/.vnc/xstartup が生成されます
$ vi /home/sangi/.vnc/xstartup

#twm & コメントアウト
追加
LANG=ja_JP.utf-8
export LANG
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE=scim
export XMODIFIERS GTK_IM_MODULE

exec gnome-session &



# service vncserver restart で再起動
realVNCで接続します。




2010/10/27追加
1:root ⇒5901を利用
2:jacc⇒5902を利用

という感じでユーザを増やすと1つずつポートを増やさなければならない。
ディスプレイ番号とポートの1の位が対応しているみたい。

2010年9月17日金曜日

OSバージョン、詳細を見る

OSディストリビューションと64bit版か確認するために使ったコマンド
# cat /etc/redhat-release
# uname -a

baculaインストール

CentOS5.5にインストールするためリポジトリにepelを設定
rpm -ivh http://download.fedora.redhat.com/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm


vi /etc/yum.repos.d/epel.repo
enable=0 としてデフォルト無効にしておきます。

# yum -y --enablerepo=epel install bacula-director


続いて
# yum –y --enablerepo=epel install bacula-storage
# yum –y
--enablerepo=epel install bacula-console
# yum -y
--enablerepo=epel
install bacula-client
今回はひとつのサーバにすべていれました。

あとは
http://www.bacula.jp/kouchiku-nyumon/yum.html
に従って設定します。

chkrootkitの導入

先日、不正侵入があったかもという連絡があったので、改ざん等ないかchkrootkitで調べました。
# yum -y --enablerepo=rpmforge install chkrootkit


# chkrootkit


確認するには
# chkrootkit | grep INFECTED
infectedとなっている部分をチェックします。
あとはcronで回してチェックしていきます。

2010年9月14日火曜日

denyhostsの導入

先日SSHブルートフォース攻撃にあいました(正確には攻撃を仕掛けた側になってしまった)。
対応方法は下記にしました。

/etc/hosts.deny にアクセスしてほしくないホストを自動追加する
⇒「denyhosts」を導入する

# yum install denyhost
リポジトリはrpmforgeより

[設定] デフォルト
SECURE_LOG = /var/log/secure
HOSTS_DENY = /etc/hosts.deny
PURGE_DENY = (解除しない)
BLOCK_SERVICE = sshd
DENY_THRESHOLD_INVALID = 5 (存在しないユーザでの認証5回まで)
DENY_THRESHOLD_VALID = 10 (存在ユーザでは10回まで)
DENY_THRESHOLD_ROOT = 1 (ルートユーザでの失敗1回まで)
DENY_THRESHOLD_RESTRICTED = 1 ( この回数より多くログインに失敗したホストをブロックする)
WORK_DIR = /usr/share/denyhosts/data
SUSPICIOUS_LOGIN_REPORT_ALLOWED_HOSTS=YES
HOSTNAME_LOOKUP=YES
LOCK_FILE = /var/lock/subsys/denyhosts
ADMIN_EMAIL = 送信先
SMTP_HOST = localhost
SMTP_PORT = 25
・・・

ひとまず様子を見てみます。

2010年9月8日水曜日

S3との連携(Java)

Amazon S3 Library for REST in Java を利用しS3に接続
http://developer.amazonwebservices.com/connect/entry.jspa?externalID=132 よりダウンロード

Eclipseに設置


Amazon Web Service のアカウントから「Access Key ID」と「Secret Access Key」を取得


EclipseでS3Driver.javaに「Access Key ID」と「Secret Access Key」を入力し、実行してみる。


creating bucket OKとなっている。コードでは
27行目
static final String bucketName = awsAccessKeyId.toLowerCase() + "-test-bucket";
となっている。
AWSのコンソールから見ると

アクセスキー+bucket nameで作成されている。
※Response createBucket(bucketName, location) - creates a bucket(Read me)より

[コンソール出力]
----- listing bucket -----
[]  ←何もないこと?

ソースでは
59行目
conn.listBucket(bucketName, null, null, null, null).entries
※ListResponse listBucket(bucketName) - lists a bucket's contents

[コンソール出力]
----- bucket location -----
    ←何も出ていなかった

ソースでは
62行目
conn.getBucketLocation(bucketName).getLocation()
※LocationResponse getBucketLocation(bucketName) - return the location-constraint of this bucket

[コンソール出力]
----- putting object -----
OK

ソースでは
S3Object object = new S3Object("this is a test".getBytes(), null);
Map headers = new TreeMap();
headers.put("Content-Type", Arrays.asList(new String[] { "text/plain" }));
System.out.println(
conn.put(bucketName, keyName, object, headers).connection.getResponseMessage());
つまり内容が"this is a test"のファイル名"test-key"で作成
key-nameは
28行目
static final String keyName = "test-key";
※Response put(bucketName, keyName, object) - writes an object

[コンソール出力]
----- copying object -----
ソースでは
conn.copy( bucketName, keyName, bucketName, copiedKeyName, null );
コピー元とコピー先のペア(bucketName, keyName)
実際にcopy-of-test-key が作成


[コンソール出力]
----- listing bucket -----
[copy-of-test-key, test-key] ←今度はファイルがある
conn.listBucket(bucketName, null, null, null, null).entries
※ListResponse listBucket(bucketName) - lists a bucket's contents

[コンソール出力]
----- getting object -----
this is a test
ソースでは
System.out.println(
new String(conn.get(bucketName, keyName, null).object.data)
);
※GetResponse get(bucketName, keyName) - retrieves an object

[コンソール残り部分]
----- query string auth example -----
Try this url in your web browser (it will only work for 60 seconds)

https://accesskey-test-bucket.s3.amazonaws.com:443/test-key?Signature=fo1Hc7VXoSiH4JwOxPACt%2Bt5zd4%3D&Expires=1283906187&AWSAccessKeyId=accesskey

press enter>

Now try just the url without the query string arguments. It should fail.

https://s3.amazonaws.com:443/accesskey-test-bucket/test-key

press enter> ----- putting object with metadata and public read acl -----
OK
----- anonymous read test -----

You should be able to try this in your browser

https://s3.amazonaws.com:443/accesskey-test-bucket/test-key-public

press enter>
----- path style url example -----

Non-location-constrained buckets can also be specified as part of the url path. (This was the original url style supported by S3.)

Try this url out in your browser (it will only be valid for 60 seconds)

https://s3.amazonaws.com:443/accesskey-test-bucket/test-key?Signature=v3kIpgwWIIWXfsXuFr4hEKhAdiA%3D&Expires=1283909712&AWSAccessKeyId=AKIAIZF2N7LMG6ARJCHA

press enter> ----- getting object's acl -----

222cddf1aaa43abe77405e83afb82547922ccc8c01cf99dd4439ce510baf807f01255525222cddf1aaa43abe77405e83afb82547922ccc8c01cf99dd4439ce510baf807f01255525FULL_CONTROL
----- deleting objects -----
No Content
No Content
No Content
----- listing bucket -----
[]
----- listing all my buckets -----
[accesskey-test-bucket, mizuno, nyonyo, sangi, watanabe-image, watanabe-image2]
----- deleting bucket -----
No Content

2010年8月19日木曜日

nagiosのホスト追加

nagiosでホストを追加するときのメモです。

# Definitions for monitoring the local (Linux) host
cfg_file=/etc/nagios/objects/localhost.cfg
とあるのでこのlocalhost.cfgをコピーして利用
cp /etc/nagios/objects/localhost.cfg /etc/nagios/objects/jacc1.sample.com.cfg

vi jacc1.toitworks.com.cfg 編集
29 host_name jacc1.sample.com ←変更
30 alias jacc1.sample.com ←変更
31 address 163.43.160.XXX ←変更

46 define hostgroup{
47 hostgroup_name jacc-servers ; The name of the hostgroup (重複不可)
48 alias Jacc Servers ; Long name of the group
49 members localhost ; Comma separated list of hosts that belong to this group (変えたらエラー:変えた方がいい?課題)
50 }

全体の host_name ⇒jacc1.sample.com

変更したら保存。
nagios -v /etc/nagios/nagios.cfg チェック

再起動
service nagios restart

2010/08/29追記
vi /etc/nagios/nagios.cfg に下記を当然追加
39 cfg_file=/etc/nagios/objects/jacc3.sample.com.cfg

2010年8月12日木曜日

CentOS リポジトリの追加

MuninをCentOS5.5にインストールしようとしたら、公式のリポジトリには登録されていなかったのでRPMforgeのリポジトリを追加した。
下記は64ビット版

# wget http://dag.wieers.com/rpm/packages/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm
# rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm

デフォルトは公式のリポジトリのままにしたいのでrpmforgeを無効にする。
vi /etc/yum.repos.d/rpmforge.repo
enable = 0 に変更

インストール
# yum --enablerepo=rpmforge install munin-node
でOK

32ビット版の場合は
#wget http://dag.wieers.com/rpm/packages/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.i386.rpm
でやってください。

2010年7月2日金曜日

CCNA(豆知識)

・no exec-timeout:時間が経ってもログアウトしない
・no logging console:exitで#に戻った時に表示をさせない

スイッチ間をtrank接続するときのケーブル⇒クロスケーブル

(スイッチ)
・自分がVTPモードのどれ(server,client,transparent)になっているか確かめるコマンド
show vtp status

Switch#show vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 5
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x7D 0x5A 0xA6 0x0E 0x9A 0x72 0xA0 0x3A
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)

・Switch0がSwitch1とどのポートでつながっているか調べる
Switch0#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce  Holdtme  Capability  Platform  Port ID
Switch0    Fas 0/1      127       S      2950     Fas 0/10

Fas 0/10が相手のポート

CCNA対策1(VLANコマンド復習)

「スイッチの設定」
[1]基本設定
(特権パスワード設定)
①特権secretパスワード設定(全体のパスワード暗号化もservice password-encryption)
②hostname設定
③コンソールパスワード設定
④リモートパスワード設定
⑤スイッチのIPアドレス設定
(config)#interface VLAN 1
(config-if)#ip address 192.168.1.2 255.255.255.0
(config-if)#no shutdown
(config-if)#exit
(config)#ip default-gateway 192.168.1.1
#show interface VLAN 1

////////////////////////////////////////////////////////////////////////////

[2]VALN作成
①VLAN作成(VLANをデータベースに登録)
#vlan database
(vlan)#vlan 2 name VLAN2
(vlan)#vlan 3 name VLAN3
(vlan)#exit

②ポートをVLANに登録
(config)#interface fa0/2
(config-if)#switchport mode access
(config-if)#switchport access vlan 2
(config-if)#end
#show vlan

③VLAN間ルーティング
(config)#interface fa0/0
(config-if)#no shutdown
(config-if)#interface fa0/0.1
(config-subif)#encapsulation dot1q 1
(config-subif)#ip address 192.168.1.1 255.255.255.0 (このアドレスがホストのゲートウェイ)
(config-if)#interface fa0/0.2
(config-subif)#encapsulation dot1q 10
(config-subif)#ip address 192.168.5.1 255.255.255.0
(config-if)#interface fa0/0.3
(config-subif)#encapsulation dot1q 20
(config-subif)#ip address 192.168.7.1 255.255.255.0
(config-subif)#end

④VTPクライアント、サーバの設定
サーバ設定(default)更新はサーバを変更しないとクライアントへは流れない。
#vlan database
(vlan)#vtp server
(vlan)#vtp domain group1 (グループ付け)
(vlan)#exit

クライアント設定
#vlan database
(vlan)#vtp client
(vlan)#vtp domain group1
(vlan)#exit

⑤トランクリンク作成
(config)#interface fa0/1
(config-if)#switchport mode trunk
(config-if)#end
各スイッチで設定

⑥スイッチの優先度指定
(config)#spanning-tree vlan 1 priority 4096
////////////////////////////////////////////////////////////////////////////////////
[3]セキュリティ設定
ホストからルータのIPアドレスに登録するとMACアドレスが登録される。show mac-address-table
①静的MACアドレスの設定 
(config)#mac-address-table static 00e0.2917.1884(MACアドレス) interface fastethernet 0/4 vlan 1
MACアドレスを登録するとそこのMACアドレスが一定になる(他のホストがつなげなくなるわけではない)

セキュリティ設定
②1つのデバイスのみ受け入れ可能
(config)#interface fa0/4
(config-if)#switchport mode access
(config-if)#switchport port-security
(config-if)#switchport port-security mac-address sticky

③各ポートのホスト数の制限
(config-if)#switchport port-security maximum 1

④セキュリティ違反があった場合はシャットダウン
(config-if)#switchport port-security violation shutdown

ポートの再アクティブ化
(config-if)#shutdown
(config-if)#no shutdown
////////////////////////////////////////////////////////////////////////////////
VLAN削除
ホスト削除
(config)#interface fa0/2
(config-if)#no switchport mode access
(config-if)#no switchport access vlan 2
(config-if)#end

VLAN全体削除
#vlan database
(vlan)#no vlan 2
(vlan)#exit

スパニングツリーの設定 show spanning-tree

スイッチの初期化
#delete flash:vlan.dat →show vlanで確認
#erase startup-config
#reload

[その他重要コマンド]
・show interfaces trunk [機器のトランクポートの情報を確認]
・show interfaces switchport [スイッチポートの管理と運用の状態を表示]

2010年6月25日金曜日

デフォルトルートの伝播



CISCOコマンド
ネットワーク中にいくつものデフォルトルートが存在すると危険性が増すしよくありません。
ひとつのルータでデフォルトルートを設定してそれをネットワーク全体で共有します。
RIP,IGRP,EIGRP,OSPFではそれぞれデフォルトルートを伝播するコマンドが異なります。

RIP:自動(default-information originate )
IGRP:ip default-network {ネットワーク番号:インターネットに接続するネットワーク}
EIGRP:redistribute static
OSPF:default-information originate

このコマンドでデフォルトルートが伝播されると「show ip route」での上にある
Gateway of last resort is not set

Gateway of last resort is 172.16.1.1 to network 0.0.0.0 (伝播ルータ)
O*E2 0.0.0.0/0 [110/1] via 172.17.1.1, 00:00:00, Serial0 (伝播されたルータ)

となります。

2010年6月16日水曜日

ロボコン

UMLの授業で使用するLEGO製のロボットが、なぜかWindows7だと認識されません。USBでロボットと接続するのですが、ロボットのドライバをWindows7が誤認識するようです。WindowsVistaでは正常に作動するのですが・・・

一度だけWindows7でも奇跡的に認識したのですが、それ以降設定を変えていないのにも関わらず一向に認識しません。解決方法を模索中です。

2010年6月15日火曜日

ウイルスバスタコーポレート版の設定


ウイルスバスタを今回導入しました。
参考書籍が少なく、情報入手に少し苦労しましたが何とか設定し運用できています。

勘違い1
今回はスマートスキャンの機能が導入され、従来型と混乱していまいました。
学内ではローカルサーバ、家では外部サーバに接続しいつでもウイルススキャン可能な状態にしたかったですが従来型ではできないようでした。
従来型がデフォルトだったのでそちらでずっとやっていました。
スマートスキャンに切り替え、「コンピュータの位置」で学校のゲートウェイを指定して、内部と外部の区別をつければ自動的に接続先サーバを切り替えてくれました。

勘違い2
スマートスキャンサーバはCorpサーバとは別でした。
Corpサーバにその機能があるのかと思い、スマートスキャンサーバを立てずに全クライアントをスマートスキャン検索に移行してしまったら全部未接続になりました(当然)。
応急処置で内部のゲートウェイを削除に全部外部にあると認識させ、すべてをトレンドマイクロ提供の外部サーバに接続させました。
あとでローカルにスマートスキャンサーバを立てて移行させます。

知りたい
スマートスキャンサーバのインストールキットをダウンロードしたところISO形式でした。ということは、Corpサーバと共存は無理?マニュアルにはできると書いてあるけど、同じ仮想環境の中にISOで共存させるにはどうすればいいのかなと考えています。

参考
スマートスキャンに関するよくあるお問い合わせ
ウイルスバスター コーポレートエディション 10.0 よくあるお問い合わせ

2010年5月17日月曜日

ルートブリッジと各種ポートの選出


スイッチ間ネットワークにおけるルートブリッジと各種ポートの選出のメモです。

1.ルートブリッジの選出(RB)
スイッチ固有のプライオリティ+MACアドレス(持っているポートで最小のもの、起動してないといけない?)
の最小のスイッチがルートブリッジになる

2.ルートポートの選出(RP)
ルートブリッジ以外で最小のパスコストのポート

3.指定ポートの選出(DP)
各セグメントでルートポート以外のポートで最小コストのもの
(ルートブリッジのポートはコスト0なので指定ポートになる)

経営工学会での発表


2010年5月15日日本大学経済学部で行われた経営工学会にて、「GoogleMAPを用いたTSPの可視化とクラウド上での運用」について行った研究の発表をしてきました。
私は同じセッションの中で1番最後の発表でした。私の前に発表を行った2人は早稲田大学の学生で非常にクオリティの高いプレゼンを行っていました。そこでハードルを上げられて、私は非常に緊張してプレゼンに臨みました。言いたいことが自然と出てこなくなり、人前で話すことの難しさを思い知りました。
次回このような発表を行う機会があったら、聞いている人達の顔をしっかり見て、胸を張って話せるようにしたいと思います。

2010年5月9日日曜日

姫野ベンチでベンチマーク測定

姫野ベンチでのベンチマーク測定のメモです。

http://accc.riken.jp/HPC/HimenoBMT/download1.html#list3
よりソースコード(C, static allocate version)S
(128 x 64 x 64)をダウンロード
lzh形式だったため、Windowsにダウンロード。
解凍すると
・himenoBMTxps.c
・Makefile
の2つのファイルができるのでそれをLinuxにFTPでアップロード

Linuxで上記の2つのファイルがあるディレクトリで以下のコマンドを実行
#make all
#ls
Makefile bmt himenoBMTxps.c himenoBMTxps.o
# ./bmt
mimax = 65 mjmax = 65 mkmax = 129
imax = 64 jmax = 64 kmax =128
Start rehearsal measurement process.
Measure the performance in 3 times.

MFLOPS: 1087.431225 time(s): 0.045431 3.288628e-03

Now, start the actual measurement process.
The loop will be excuted in 3962 times
This will take about one minute.
Wait for a while

Loop executed for 3962 times
Gosa : 5.163313e-06
MFLOPS measured : 1194.469889 cpu : 54.622567
Score based on Pentium III 600MHz : 14.566706

これをcronで行い、集計します。

date >>/root/Desktop/himeno/log/log.txt;
/root/Desktop/himeno/bmt >>/root/Desktop/himeno/log/log.txt;
echo >>/root/Desktop/himeno/log/log.txt;
echo >>/root/Desktop/himeno/log/log.txt;
echo >>/root/Desktop/himeno/log/log.txt;

とりあえずこれで様子を見て、log.txtをDBに入れるスクリプトをつけて集計しようと思います。

2010年4月16日金曜日

巡回セールスマン問題メモ

多項式時間(n,n^2,n^3,nlognなど)で解けるアルゴリズム⇒polynomial-time solvable クラスP

ある問題がクラスPであることを証明⇒多項式時間アルゴリズムを1つでも探せばよい

巡回セールスマン問題:多項式時間アルゴリズムが存在しないことが予想されている(証明できていない)
不可能を証明することはとても難しい!!

巡回セールスマン問題⇒NP完全問題に分類(みんなが難しいといっているので難しい!)

クラスNPについては勉強の必要あり(一読ではよくわかりません)

2010年4月7日水曜日

Virtual boxでの複製

Virtual Boxの複製のメモです。
1.cd C:\Program Files\Sun\VirtualBox へ移動
2.C:\Program Files\Sun\VirtualBox>VBoxManage clonevdi D:\VirtualBox\XP_Pro.vdi D:\
VirtualBox\XP_Pro1.vdi

XP_Pro.vdiが元、XP_Pro1.vdiが新規

簡単にできました。

就職内定体験談

就職内定体験談です。今回は静岡県内にSEとして内定したN09015君の体験談です。

1:内定企業
静岡県内企業
職種:SE

2:内定までのプロセス
会社説明会(説明会でエントリーシート配布)→書類選考→適性検査&一次面接→最終面接→内定

3:自分で特に頑張った事
エントリーシートや面接でのネタ作り(駅伝に参加・野球部・学校の手伝いなど)。
業界研究のために、ソフトウェア業界の会社説明会は、興味のない企業でも回った。
(いろいろな企業を回ると、自分の希望している企業の強みが分かります。)
就職課に、まめに通って情報収集やエントリーシートの添削をしてもらう。

4:自分が内定した理由
なぜその企業でなければならないのか、その理由をちゃんと言えた。
面接で自分をアピールするのに、説明会で人事の人が言っていた「求める人物像」に
当てはまるように、アピールした。
学校外での活動が、良いアピールになった。

5:これから就職活動をする人達にメッセージ
最終面接の後に、自分の選考時の評価を教えてもらえる機会があった。その時に、
適正検査では「SEに向いているか」以外にも、意外に「営業に向いているか」も重視していて、
面接ではコミュニケーション能力があるかもチェックしていると言っていた。なので、
よく言われますが、「会話のキャッチボール」が、すごく大事だと思います。
あと、エントリーシートを提出する前に、就職課の先生か担当の先生に添削してもらって
ください。買い手市場のため、1つの企業にたくさんの応募者がいて、書類選考を
通過するのが難しいからです。
最後に、内定に辿り着くには情報収集や準備が大事だと思います。
そのために就職課の先生や担当の先生をフル活用してください。そうすれば、
内定につながるはずです。

以上、ありがとうございました。

使えるネット FTP設定

使えるネットのVPSサーバを用いてFTPを作る時のメモです。

使えるネットのVPSサーバにはProftpがデフォルトでインストールされている。
なのでそのまま設定します。
設定ファイル vi /etc/proftpd.conf
ユーザ制限ファイル(これにのっていると接続できない)  vi /etc/ftpusers
再起動 /etc/rc.d/init.d/xinetd restart

これで接続できます。

htdocsは
/var/www/vhosts/default/htdocs
なので注意が必要です。

2010年4月5日月曜日

大学への移動

大学へは以外とバスも便利です。

静岡盲学校前 停留所 (大谷草薙方面)
http://apps.justline.co.jp/nanj/table_frm.do?busstopcode=11635&dataType=1&polecode=2&paperNumber=1
(発)静岡盲学校前 ⇒ (着)英和学院大学池田山団地
運賃 路線名
\250 静岡日本平線

(発)静岡盲学校前 ⇒ (着)静大前
運賃 路線名
\230 美和大谷線

定期金額

また帰りは
英和学院大学池田山団地 停留所 (新静岡方面)
http://apps.justline.co.jp/nanj/table_frm.do?busstopcode=12145&dataType=1&polecode=1&paperNumber=1

静大前 停留所 (新静岡方面)
http://apps.justline.co.jp/nanj/table_frm.do?busstopcode=11965&dataType=1&polecode=1&paperNumber=1 (発)静大前 ⇒ (着)静岡駅前
運賃 路線名
\280 美和大谷線
静大からの帰りは静岡駅がほとんどです。

2010年3月30日火曜日

Default Userの作成

新しくユーザを作成する場合に設定項目を継承したい場合はDefault Userの設定をします。
下記を参考にしました。
http://sites.google.com/site/syslogweb/home/windowsxp/userprofile/defaultuser

情報処理試験解説(待ち行列)

待ち行列の解説です。

待ち行列理論で覚えなければいけないのは次の項目です。


利用率 ρ=λ×E[S]

λ:到着率、E[S]は平均サービス時間


2010年3月23日火曜日

受かりました。

お久しぶりです。n09011です。
きょう正式にMOT合格通知が来ました!
私の先輩にあたる方は頭がよかったので当たり前ですが、
私のような知識レベルの低い人間でも、がんばれば合格できるんだと感じました。
これは今就活やってるのでそれにも役立ちそうです。
最後に、2時間前まで私の編集を手伝ってくださった、先生方にお礼を述べて終わらせていただきます。
4月から院生と両立ですが、頑張りたいと思います。
ではこのへんで。

2010年3月14日日曜日

やっと終わりました。

こんにちはn09011です。
久しぶりすぎる投稿です。
今日MOTの試験を受けてきました。
笑いはいただきましたが、
いかなものか。
たぶんダメだろうと思いながら、
とりあえず熱意だけは伝えてきました。
合否については22日を過ぎたらわかるので、
そしたら載せます。たぶん落ちてる(笑)
ではでは、

2010年3月5日金曜日

CCNA更新のためICND2を受験しました。

今週、CCNAの更新をしなければならなかったので試験を受けてきました。
本当はCCNPのどれか一つの試験を受ける予定でしたが、学生が今度ICND2を受験するので急遽変更し、ICND2を受けてきました( http://www.cisco.com/go/recertification 参照)。

感想は「時間が足りない」です。75分間で49問。しかも1問当たり5設問があったり、シミュレーションがあったり残り20秒程度しか残りませんでした。

詳しい内容は書けませんがアドバイスとしては
・IPアドレスの計算は素早くできるように。
・スパニングツリーは完ぺきに。
・シミュレーション問題は簡単ですが、その問題の趣旨を素早く理解できるように。
・1問当たり1分30秒程度しかありません。解りきっている問題は素早く次へ。
・showコマンドは大切です。
・問題集で問題を覚えておいただけでは到底受かりません。しっかり理解してどんな問題にも対応できるように。

それでは学生のみなさん、がんばりましょう。

2010年2月21日日曜日

浜松ITカンファレンス2010に行ってきました

2010年2月20日に浜松ITカンファレンス2010(アクトシティ 研修交流センター 音楽工房ホール)に行ってきました。
まつもと ゆきひろ 氏、宮原 徹 氏、杉山 恵一郎 氏
の講演でした。やはり第一線で活躍している人の話は面白いですね。
以下に、気付いた点を書いておきます。

杉山さん HTML 5.0&CSS 3.0が与える今後のITビジネスへの影響
CSS1.0 1996年開始 →CSS2.1 IE7で採用(2008)
デザイナの採用が変わってきている
昔 HTML作成者
近年 Dreamweaver, Fireworksの使える人
今 photoshop
現在はデザイナはデザインに徹し、コーダがHTML+CSS+Javascript を行う
androidOSでHTML5.0よりAIRの方がおもしろい
プロジェクト管理はWIKIを使っている。

宮原さん プロが教える仮想化入門
復旧などのネガティブコスト(トラブル時正常に戻すのみ)は減らさなければならない。
仮想化前:個別最適化
仮想化利用:全体最適化
仮想化を行うと
運用コスト→下がる
導入コスト→変わらない
仮想化→I/Oがボトルネックになりやすい
クラウド利用:コストの適正化(削減ではない)
VIrtual box 3.1 テレポーテション 面白そう
SSD FC-SANに比べ37倍の性能(ベンチマーク:TPC-B)

まつもとさん
Rubyは1993年2/24に誕生
Rubyという名前はPerl(真珠?)に対抗してたてた(名前な重要)
2004 Ruby on Rails
2008 Rubyユーザ100万人弱 By ガートナー
2013 には400万人
家での仕事は家族が寝てからやっている。

おもしろい研修会でした。また参加してみたいと思います。

2010年2月8日月曜日

WORDでの参考文献作成

WORDでの参考文献作成はやったことがなかったのでメモしておきます(いままではTEXでやっていた)。

1.IEEEのスタイルを追加します。
http://www.codeplex.com/bibword からBibWord stylesをダウンロードし、C:\Program Files\Microsoft Office\Office12\Bibliography\Styleに入れます。

2.参考資料⇒引用文献の挿入⇒新しい資料文献の追加 から登録します。
スタイル:IEEE Reference Orderにしておきます。

3.資料文献の管理で試行錯誤(順番が狂ったり、細かいところでうまくいかないです)

4.引用文献の挿入 で番号をいれていく。あとは最後に目録を作ります。

以上です。

2010年2月2日火曜日

ラボ実習 11.2.2a 拡張アクセスリストの設定

今回は授業の代わりということなので「実況中継」形式で書きます。

今回のテーマは拡張アクセスリストです。前回標準アクセスリストをやりました。標準アクセスリストはIPアドレスで対象が決定するので、IPアドレスがひっかかればどんなプロトコルでも止まってしまったりします。IPアドレスで通信の許可、不許可を決めると柔軟性がありません。例えば、「HTTPは使いたいけど、FTPはいらない」という風です。プロトコルごと決められる拡張アクセスリストを勉強します。

拡張アクセスリストの書式
(config) # access-list 番号 deny(permit) tcp(ip,icmp) 送信元ネットワークアドレス 送信元ワイルドカードマスク 宛先ネットワーク 宛先ワイルドカードマスク eq ポート番号

tcpの部分はプロトコルを指定します。tcpを指定すると最後にポート番号を指定してプロトコルを指定できます。
ネットワークの書き方はFROM TO の順番です。
ワイルドカードマスクはサブネットマスクのビット反転したものです。255から引いてもいいです。

例を見て理解しましょう。

拡張アクセスリストの例
①192.168.14.0/24がtelnetを実行できないようにする
(config)# access-list 101 deny tcp 192.168.14.0 0.0.0.255 any eq 23
(config)# access-list 101 permit ip any any
(config)# interface fa0
(config-if)# ip access-group 101 in
2行目のpermit ip any any は暗黙のdeny ip any anyを回避している。


②host 198.77.116.7からhost 12.0.0.3へのアクセスをブロック
(config)# access-list 101 deny ip host 198.77.116.7 host 12.0.0.3
(config)# access-list 101 permit ip any any
(config)# interface fa0
(config-if)# ip access-group 101 in

③13.0.0.5から12.0.0.14へのtelnetを許可(あとはだめ)
(config)# access-list 101 permit tcp host 13.0.0.5 host 12.0.0.14 eq 23
(config)# interface s0
(config-if)# ip access-group 101 in

暗黙のdeny ip any anyがあるのでpermitしたものだけ通過できる。

④192.168.12.0から192.168.13.0へのtcpトラフィックを許可しない
(config)# access-list 101 deny tcp 192.168.12.0 0.0.0.255 192.168.13.0 0.0.0.255
(config)# access-list 101 permit ip any any
(config)# interface s0
(config-if)# ip access-group 101 out

⑤192.168.12.0から192.168.11.0へ向かうftp以外をブロック。(あとはOK)
(config)# access-list 101 deny tcp 192.168.12.0 0.0.0.255 any eq 21
(config)# access-list 101 permit ip any any
(config)# interface s0
(config-if)# ip access-group 101 out


アクセスリストをinにするのかoutにするのか区別がついてきましたか?
in:セキュリティ対策をやりやすい(ルータに入る前にカット)
out:トラフィックコントロール(パケットをどこに向かわせるかを設定)
こんな感じで考えてください。

次回に名前付きアクセスリストをやりますが、これは標準アクセスリストと拡張アクセスリストの番号をやめて、自分で名前をつけます。
つまり名前を付けれれるだけで、機能は標準アクセスリストと拡張アクセスリストと何も変わりません。
ということは標準アクセスリストと拡張アクセスリストができれば名前付きは難しくありません。